RVM on Ubuntu Troubles

advertisements

I've run into a lot of issues whilst attempting to install RVM on Ubuntu 9.10. Here's the steps I've tried doing:

  • install ruby (via ruby site, no package manager)
  • download rvm
  • install rvm (make edit to .bashrc)
  • use rvm to install ruby version & gems

Is there any crucial step that I seem to be missing?


Be sure to have selected an installed ruby (the --default portion tells rvm you want this ruby to be your default ruby version). Something like:

rvm --default use 1.9.2

Also this command will tell you which ruby is currently selected:

rvm list

And hopefully you'll see something like:

rvm rubies

   ruby-1.9.2-p0 [ x86_64 ]
=> ruby-1.8.7-p302 [ x86_64 ]

At this point, you'll be able to install gems and hopefully have a successful rvm install and working environment.

I've had issues in the past where I didn't have an rvm ruby selected and was still working with my distribution's ruby and gems and got mixed up easily. Make sure you're ruby and gem commands are working out of your ~/.rvm folder whith the following commands:

which ruby
which gem

Good luck!