Magento installation - The database server does not support the InnoDB storage engine

advertisements

I'm trying to install Magento on my local server (WampServer 2.4), using magento downloader, but I get following error while cheking database connection in first step of this installatoin.

Database server does not support InnoDB storage engine

it maybe because of the mysql version which is 5.6.12, but I couldn't downgrade it. also when I change the my.ini file to enable InnoDB engine as follow mysql service didn't start.

# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = C:\mysql\data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:\mysql\data/
innodb_log_arch_dir = C:\mysql\data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

also here is the result of running show engines command:

I also try install using full release of it, but I get following error:

Warning: require(app/Mage.php): failed to open stream: No such file or directory in C:\wamp\www\magento\install.php on line 125

Fatal error: require(): Failed opening required 'app/Mage.php' (include_path='C:\wamp\www\magento;.;C:\php\pear') in C:\wamp\www\magento\install.php on line 125 Call Stack

also it didn't contain app/code/core/Mage/Install/Model/Installer/Db/Mysql4.php so I couldn't try solution in similar question.

could anyone help me to fix this issue?


If you have downloaded the package from Magento, 1.9.1 definitely includes the file app\code\core\Mage\Install\Model\Installer\Db\Mysql4.php - so I would expect that this hasn't extracted correctly on your system. You should see that 1.9.1 actually already includes the fix you mention (change from have_innodb).