Link to libcrypto for Leopard?

advertisements

I am using Mac OS X 10.6 SDK and my deployment target is set to Mac OS 10.5. I'm linking to libcrypto (AquaticPrime requires this) and found out that my app doesn't launch on Leopard. The error is

dyld: Library not loaded: /usr/lib/libcrypto.0.9.8.dylib

I've tried the following workarounds but none of them work:

  • Linking directly to libcrypto.0.9.7.dylib (the 10.6 SDK refuses to link directly with libcrypto.0.9.7.dylib.
  • Copying the 10.5 SDK's version of libcrypto.0.9.7.dylib to the 10.6 lib directory and try t link with it (this time the link process succeeded but in Leopard the app still tries to lookup the non-existent libcrypto.0.9.8.dylib file and thus won't launch).
  • Copying libcrypto.0.9.7.dylib from a Mac OS X 10.5.8 installation and link with it (the link was successful but the app still looks for libcrypto.0.9.8.dylib).

Is there a way to link to this library and still use the 10.6 SDK?

Thanks.


You could try setting the base SDK to 10.5 in your target build settings.