java.lang.Object can not be resolved. It is indirectly referenced from the required .class files.

advertisements

i am using eclipse 3.2 version. in sametime based i am getting error on package: java.lang.Object can not be resolved. It is indirectly referenced from required .class files.

on build path JRE is JRE System Library [JavaSE-1.6] (unbound)

when i set the JRE is JRE System Library [jclDesktop Win32 x86] then it give others errors like on function name of other classes.


There are a lot of differences between jclDesktop and Java 5. Which means, that Java code, written for Java 5 (or any other Sun/Oracle Java) will probably not compile with jclDesktop.

You can use jclDesktop as a JRE system library if you want to write applications for jclDesktop. If you have one Java application and want to convert it to jclDesktop, then you'll have to resolve all the compile time errors (and hope for the best).

Otherwise, install an Oracle Java SDK (JRE is enough although I'd recommend a JDK which comes with the src.zip file) and use that as JRE library.