iAd Banner does not appear but the code and right & hellip; I can not find a solution

advertisements

I have a problem with iAd I have followed many tutorials that are of excellent quality, and a few days ago I was able to correctly insert iAd in a test application. Now the method does not work even if I try to create a new application with only the iAd as a test! I can not understand the problem appears to me the following text:

I use xCode 5 and iOS 7 SDK

iAD prova[3158:a0b] [AppDeveloper] ADBannerView: Unhandled error (no delegate or delegate does not implement didFailToReceiveAdWithError:): Error Domain=ADErrorDomain Code=3 "The operation couldn’t be completed. Ad inventory unavailable" UserInfo=0xa5aaaf0 {ADInternalErrorCode=3, ADInternalErrorDomain=ADErrorDomain, NSLocalizedFailureReason=Ad inventory unavailable} 2013-09-20 12:24:59.887 iAD prova[3158:a0b] [AppDeveloper] ADBannerView: Unhandled error (no delegate or delegate does not implement didFailToReceiveAdWithError:): Error Domain=ADErrorDomain Code=5 "The operation couldn’t be completed. Banner view is visible but does not have content" UserInfo=0xa5af280 {ADInternalErrorCode=5, ADInternalErrorDomain=ADErrorDomain, NSLocalizedFailureReason=Banner view is visible but does not have content}

There are errors in the code, I read about this user "ajay" who posted this:

HI all finally i solved problem my self none of the blog didnt give any solution.I am not getting Test ad in the simulator it is coming in the device only by changing of the internal proxy settings.Its good experience for me and also my suggestion is while your operating with IOS device make sure to take proxy free device so that at least you can eliminate some of the issue related to proxy, dont forget to work proxy related stuff at the end product:)

But I can not understand how I should proceed Help me guys thanks


Also, you can change your fill rate in Settings.app. Set it to 100% if you want it to show up all the time.