I upgraded my application from struts 2.0X to 2.1X for using the jquery grid plugin But getting an error

advertisements

I upgraded my app from struts 2.0X to 2.1X for using jquery grid plugin But getting a following error .

Caused by: Unable to load bean: type:com.opensymphony.xwork2.util.ValueStackFactory class:com.opensymphony.xwork2.ognl.OgnlValueStackFactory - bean - jar:file:/F:/Jportalsvn/trunk/Jportal/build/web/WEB-INF/lib/struts2-core-2.2.3.jar!/struts-default.xml:71:140


In first short it seems that the error is most likely is being caused by sets of jars competing causing an environment issue.Make sure you have no jar conflict as indicated for struts2-core-2.2.3.jar.

Try doing a complete clean and redeploy and make sure that the old libraries are not being deployed or are still there.

Hope this should resolve your problem and if it still persist i suggest you to go for a small steps like creating a small hello-world application to check if everything is fine and workin properly.