How do I resolve a & ldquo; Error reading signed content. & Rdquo; Error installing ADT 23.0.2 in Eclipse 4.4 on OSX

advertisements

I've been trying to install the Android Developer Tools (ADT 23.0.2) in Eclipse 4.4 on OSX . When I do, I get the following error message:

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.

session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).

Error reading signed content.

error in opening zip file

This problem happens both when I try to install it directly from the Android Repository, and when I try to install it from a file that I've downloaded locally.

Any idea how to resolve this?


I had exactly the same issue, and I found that if I installed the components one at a time (instead of the whole lot all at once) it worked... But then a week or so later I tried installing some other Eclipse software from the Luna repository (it was the C++ Developer Tools) and I got the same error. Then after a bit of Googling I found this: eclipse error when try install plugin

So basically if you delete all the artifacts.xml files under your eclipse directory the problem goes away. Here are the commands I used:

cd /opt/eclipse
find -name artifacts.xml -execdir rm {} \;

I don't really know what the artifacts.xml files are for, but I am just happy to be able to install stuff again without having to start from a fresh Eclipse install. I hope you find this useful. :-)