Can not switch between emulators or Windows Phone devices

advertisements

I'm trying to port our existing windows phone 7.5 app to be available for our windows phone 8 users in Visual studio 2012. The app has been developed in Visual studio 2010, on a windows 7 machine. I have a new laptop set up with Windows 8 and visual studio 2012, on which everything works like a charm. I can create new projects, use the different emulators and test windows phone projects on my windows phone 8 test device.

Once I open the windows phone 7.5 app solution in visual studio 2012, things go bad. I can only test the app on the "Emulator WVGA 512MB". When i try to change the emulator to a device, or even a different emulator, nothing happens. No errors, no exceptions.

There's definitely something with my solution, but i can't figure out what. The project's properties and debug configuration seems to be exactly the same as on my windows 7 pc. The targeted OS Version is still windows phone OS 7.1. Can anyone with similar experience give me a pointer? I have no idea, even the eventlog can't help me out.


@Mixx, you said "When i try to change the emulator to a device, or even a different emulator, nothing happens. No errors, no exceptions." Do you mean you changed the selection from the dropdown in the toolbar? If yes, just changing that selection does not start any action. It just changes the selection/target device for the next time you run your app.

After changing the selection, hit F5 to run the app in the selected target environment (emulator or device). Hope this helps!